Scicos Blocks

From ErikaWiki

Jump to: navigation, search

Contents

Introduction

Here a basilar description of scicos blocks for FLEX and Easylab boards. Each of these blocks has a more complete description integrated with scicos help feature. To acces to them just right click on a block and select help from contextual menu.

Code generation general purpose palettes

These are the palettes for code generation that do not depend on target board (for further info open the Scicos Help feature)

  • MCHP16 Sources
  • MCHP16 Sinks
  • MCHP16 Linear
  • MCHP16 Non Linear
  • MCHP16 Logic
  • MCHP16 Branching
  • MCHP16 Typeconversion

FLEX & Daughter boards palettes

This is a short description of the palettes available on the Scicos Pack for FLEX and her daughter boards (for further info open the Scicos Help feature).

  • FLEX-DemoBoard
  • FLEX-MotionBoard
  • FLEX
  • FLEX-Communication

RT Data Exchange Palette

Palette with all the blocks to perform communication between a PC simulation and the target boards (NOT FOR CODE GENERATION) (for further info open the Scicos Help feature)

  • RT Data Exchange

Amazing Ball palette

This is a short description of the blocks available for the AMAZING BALL system (for further info open the Scicos Help feature)

  • Amazing Ball

Easylab board palette

This is a short description of the blocks available for the EASYLAB board (for further info open the Scicos Help feature)

  • Easylab

Miscellaneous palette

This palette contains general purpose blocks available for AMAZING BALL, FLEX and EASYLAB (for further info open the Scicos Help feature)

  • Miscellaneous blocks (SPRINTF)

Note: To compile this block a recent version of the Microchip compiler is needed. Recommended versions: v3.30, v3.31 or later. Please do not use v3.25!

SMCube palette

This palette contains blocks for FSM-based applications (for further info open the Scicos Help feature)

  • SMCube blocks (SMCUBE)

Note: To compile this block a recent version of the Microchip compiler is needed. Recommended versions: v3.30, v3.31 or later. Please do not use v3.25!

Personal tools