Installation of Mico32/FPG-EYE development environment

From ErikaWiki

(Difference between revisions)
Jump to: navigation, search
(Introduction)
(Introduction)
Line 3: Line 3:
This tutorial describes a set of steps needed to compile and deploy a platform on FPG-EYE board.
This tutorial describes a set of steps needed to compile and deploy a platform on FPG-EYE board.
-
To achive this goal you need follow softwares from Lattice installed in your environment:
+
To achive this goal you need follow softwares from Lattice installed in your environment (follow links for download pages):
-
*[http://www.latticesemi.com/products/designsoftware/isplever/isplever/index.cfm ispLEVER]
+
*[http://www.latticesemi.com/dynamic/index.cfm?fuseaction=view_documents&document_type=65&sloc=01-01-07-55-23-01&source=sidebar ispLEVER]
-
*[http://www.latticesemi.com/products/designsoftware/ispvmsystem/index.cfm ispVM System]
+
*[http://www.latticesemi.com/dynamic/index.cfm?fuseaction=view_documents&document_type=65&sloc=01-01-07-30&source=sidebar ispVM System]
-
*[http://www.latticesemi.com/products/designsoftware/micodevelopmenttools/index.cfm LatticeMico32 System (aka MSB)]
+
*[http://www.latticesemi.com/dynamic/index.cfm?fuseaction=view_documents&document_type=65&sloc=01-01-07-20&source=sidebar LatticeMico System Development Tools (aka MSB)]
-
Consult [http://www.latticesemi.com/products/designsoftware/index.cfm?source=topnav Lattice Design Software] web page to download the softwares and to get a free license to use it (you need a free registration to do it).
+
To download and use these softwares you need a Lattice registration and a fre license (follow instruction on [http://www.latticesemi.com/licensing/index.cfm Lattice web site])
 +
Be careful each version of ispLEVER need a correspondent version of LatticeMico System Development Tools. In regard to ispVM System you need version 18.0 or superior.
 +
All FPG-EYE development has been made with ispLEVER 8.0 and correspondant LatticeMico System Development Tools.
== Standard Mico32 components Patches ==
== Standard Mico32 components Patches ==

Revision as of 16:16, 28 September 2011

Introduction

This tutorial describes a set of steps needed to compile and deploy a platform on FPG-EYE board.

To achive this goal you need follow softwares from Lattice installed in your environment (follow links for download pages):

To download and use these softwares you need a Lattice registration and a fre license (follow instruction on Lattice web site)

Be careful each version of ispLEVER need a correspondent version of LatticeMico System Development Tools. In regard to ispVM System you need version 18.0 or superior.

All FPG-EYE development has been made with ispLEVER 8.0 and correspondant LatticeMico System Development Tools.

Standard Mico32 components Patches

Personal tools