Installation of Mico32/FPG-EYE development environment

From ErikaWiki

(Difference between revisions)
Jump to: navigation, search
(Introduction)
Line 16: Line 16:
== Standard Mico32 components Patches ==
== Standard Mico32 components Patches ==
 +
 +
During FPG-EYE software development we found and correct a few bugs in standard Mico32 components. Especially we found bung in following components:
 +
 +
* SPI Flash Controller (Component folder: spi_flash. Verilog files: spi_flash_intf.v wb_intf.v)
 +
* Async SRAM Controller (Componet folder: asram_top. Verilog files: asram_core.v)

Revision as of 09:37, 29 September 2011

Introduction

This tutorial describes a set of steps needed to compile and deploy a platform on FPG-EYE board.

To achive this goal you need follow softwares from Lattice installed in your environment (follow links for download pages):

To download and use these softwares you need a Lattice registration and a fre license (follow instruction on Lattice web site)

Be careful each version of ispLEVER need a correspondent version of LatticeMico System Development Tools. In regard to ispVM System you need version 18.0 or superior.

All FPG-EYE development has been made with ispLEVER 8.0 and correspondant LatticeMico System Development Tools.

Standard Mico32 components Patches

During FPG-EYE software development we found and correct a few bugs in standard Mico32 components. Especially we found bung in following components:

  • SPI Flash Controller (Component folder: spi_flash. Verilog files: spi_flash_intf.v wb_intf.v)
  • Async SRAM Controller (Componet folder: asram_top. Verilog files: asram_core.v)
Personal tools